Funkcja SUMA.ILOCZYNÓW

Mnożenie liczb w jednej kolumnie przez liczby w drugiej oraz sumowanie uzyskanych wyników jest działaniem dość powszechnym; szczególnie dotyczy to arkuszy wspomagających sprzedaż lub inwentaryzację. Artykuł opisuje funkcję SUMA.ILOCZYNÓW, która ułatwia to zadanie.

Zamieszczony poniżej zrzut ekranu przedstawia zbiór danych, na którym będę pracował. W pierwszej kolumnie znajduje się nazwa produktu, w następnych zaś jego cena jednostkowa i liczba kupionych sztuk. Arkusz ten może przedstawiać artykuły szkolne zakupione do kiosku.

Okno programu Calc przedstawiające przykładową bazę danych.

Naszym celem jest znalezienie odpowiedzi na pytanie — ile pieniędzy potrzeba, aby kupić wszystkie wymienione produkty?

Pierwsze rozwiązanie opiera się na wykorzystaniu kolumny tymczasowej. W komórce D2 wprowadzamy formułę obliczającą iloczyn wartości z komórek B2 i C2, a następnie kopiujemy ją do komórek poniżej. W innej komórce, np. E2, obliczamy sumę wartości w kolumnie D.

Okno programu Calc. W kolumnie D obliczono iloczyn komórek z kolumn B i C w tym samym wierszu. W komórce E2 obliczono sumę wyników z kolumny D.

Sposób ten ma jednak dwie wady. Po pierwsze, do przedstawienia zaledwie jednej liczby potrzeba całej kolumny komórek. Po drugie, zmiana bazy danych (np. dodanie kilku nowych pozycji) wiąże się z dokonaniem poprawek w kilku miejscach. W dłuższej perspektywie jest to jednak uciążliwe.

Zamiast tego można wykorzystać funkcję SUMA.ILOCZYNÓW. W naszym przypadku wygląda ona następująco:

=SUMA.ILOCZYNÓW(B1:B20;C1:C20)

Funkcja ta przyjmuje jako argumenty zakresy komórek. Następnie mnoży odpowiadające sobie ich elementy, a na końcu sumuje uzyskane wyniki.

W powyższym przypadku funkcja wpierw bierze pierwszy element z pierwszego zakresu (B1) i mnoży go przez pierwszy element z drugiego zakresu (C1). Następnie drugi element z pierwszego zakresu mnoży przez drugi element z drugiego zakresu. Operację tę powtarza dla pozostałych elementów. Wreszcie dodaje do siebie otrzymane wyniki. Działanie to można zapisać w następujący sposób:

(B1 × C1) + (B2 × C2) + (B3 × C3) + (B4 × C4) + … + (B20 × C20)

Przyjrzyjmy się jeszcze jednemu przykładowi. Do naszej bazy dodajmy dwie kolumny — jedna z ceną detaliczną sprzedaży, druga z liczbą sprzedanych sztuk.

Okno programu Calc przedstawiające przykładową bazę danych z dodanymi dwiema kolumnami

Dzięki tym informacjom policzyć możemy utarg ze sprzedaży przyborów szkolnych. Nas jednak bardziej interesuje, czy inwestycja się zwróciła; jeżeli tak — ile wyniósł zysk netto? Informację tę możemy uzyskać przy pomocy jednej prostej formuły:

=SUMA.ILOCZYNÓW(D1:D20;E1:E20)-SUMA.ILOCZYNÓW(B1:B20;C1:C20)

Formuła ta najpierw liczy całkowity zarobek ze sprzedaży produktów a następnie całkowite koszty zakupienia towaru. Na końcu odejmuje drugą liczbę od pierwszej. Wynik dodatni świadczy o tym, że inwestycja zwróciła się; wynik ujemny — że nie była opłacalna.

Chociaż funkcja SUMA.ILOCZYNÓW zazwyczaj pracuje na dwóch zakresach jednowymiarowych (zawierających tylko jedną kolumnę lub tylko jeden wiersz), nie jest to koniecznością. Argumentów może być więcej; mogą nimi również być zakresy dwuwymiarowe. Sytuacje te przedstawiają poniższe formuły i odpowiadające im zrzuty ekranu. Dla zwiększenia ich czytelności, odpowiadające sobie komórki w zakresach oznaczyłem takimi samymi kolorami.

=SUMA.ILOCZYNÓW(A1:C3;A5:C7)
=SUMA.ILOCZYNÓW(A1:A4;C1:C4;E1:E4)

Podczas pracy z opisywaną funkcją należy pamiętać o tym, aby wszystkie zakresy miały takie same wymiary (taką samą liczbę kolumn oraz wierszy). Jeżeli warunek ten nie zostanie spełniony, zwrócony zostanie błąd.

Poza tym warto wiedzieć, iż tekst jest traktowany jako zero. Dzięki temu komórki tekstowe nie wpływają na wynik obliczeń.

Podobał Ci się ten artykuł? Zapisz się na listę subskrybentów i otrzymuj informacje o następnych

Dodaj komentarz